The messaging outage affecting Instagram and Facebook has been resolved. Full functionality has been restored across all affected channels. Our team will continue to monitor performance to ensure stability. We appreciate your patience and understanding during the disruption.
Posted Jun 12, 2025 - 16:14 IST
Identified
We've identified the root cause of the messaging issues affecting Instagram and Facebook. Our teams are actively working on a fix to restore full functionality. Users may continue to experience intermittent issues with sending or receiving messages while we implement the solution.
Posted Jun 12, 2025 - 13:52 IST
Investigating
We are currently investigating an issue affecting messaging functionality on Instagram and Facebook. Users may experience delays or failures when sending or receiving messages on these platforms. Our engineering team is actively working to identify the root cause and will provide updates as we learn more.
Posted Jun 12, 2025 - 12:40 IST
This incident affected: Instagram & Facebook Messaging.